Nieuws: Heb je vragen over de werking van het 3railforum? Krijg deze beantwoord in de Forumtips.
+  3rail Forum
|-+  Modelbaanbesturing & Software
| |-+  PC Besturingsoftware
| | |-+  Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
0 leden en 1 gast bekijken dit topic. « vorige volgende »
Pagina's: [1]   Omlaag

Auteur Topic: Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet  (gelezen 303 keer)

1200Blauw

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2009
  • NS Tp.IVa (1968-1981)
Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
« Gepost op: zaterdag 02 januari 2021, 10:51:59 »

Ik ben bezig met pionieren in Rocrail. Nu loop ik aan tegen het geautomatiseerd aan laten maken van rijwegen door Rocrail. AlbertG laat in zijn filmpjes zien dat dat kan door Bestand/Routeren/Trace. Om te zien of dat gelukt is kun je kijken in Tabellen/Rijwegen. Bij mij blijft die rijwegentabel leeg. Albert geeft aan dat je dan moet kijken of in Bestand/Rocrail Eigenschappen het vinkje aanstaat bij "Routeren Activeren". Dat is bij mij het geval. Ik heb 'm zelfs een keer uitgezet, Rocrail afgesloten en opgestart en weer aangezet (Rocrail uit+Aan). Nu ben ik eigenlijk uit opties. Iemand een idee?
Gelogd

RocnetHans

  • Vaste Gast
  • **
  • Offline Offline
  • Lid sinds: 2016
  • Ik klooi eigenlijk maar wat aan
    • Scheldekaai
Re: Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
« Reactie #1 Gepost op: zaterdag 02 januari 2021, 11:33:44 »

Wellicht zit er nog een fout in je baanplan waardoor het niet lukt.
je kunt het laten controleren in Bestand -> Router -> uitgebreide spoorplantest.

wat zegt de Server monitor tijdens het aanmaken?
Gelogd
vr. groet, Hans

dioramabaan "Scheldekaai"
Besturing: digitaal, PC met Rocrail. centrale: DCC++ en Rocnet op Raspberry Pi.
Programmeerspoor met SPROG IIv4
https://forum.3rail.nl/index.php?topic=61263.900

[img]http://files.3rail.nl/419.gif

1200Blauw

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2009
  • NS Tp.IVa (1968-1981)
Re: Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
« Reactie #2 Gepost op: zaterdag 02 januari 2021, 12:45:04 »

Hartelijk dank Hans! Dat de Server Monitor me hints zou geven was een goede tip. Wel dom dat ik er zelf niet aan had gedacht. Je tip over de Spoorplantest maakte het plaatje voor de foutopsporing compleet. Zo kon ik de fouten in het baanplan opsporen en verhelpen.
Ik had een stuk van de baan nog buiten gebruik maar wel alvast getekend, met als gevolg dat er meldingen kwamen over wissels zonder geldig adres etc. Die heb ik uit het baanplan gehaald en ook teksten van blokken die over naastliggende rails vielen (wordt geïnterpreteerd als een blok over twee baanvakken, met als gevolg een blok met twee namen) verholpen. Nu heb ik een foutloos vereenvoudigd baanplan met gegenereerde rijwegen. Later zal ik er de overige sporen aan toevoegen, maar eerst dit maar eens rijdend krijgen.

NB De tag [ /img] (zonder de spatie) nog even toevoegen aan je onderschrift, dan wordt je fraaie Plan V zichtbaar.
« Laatst bewerkt op: zaterdag 02 januari 2021, 12:47:09 door 1200Blauw »
Gelogd

RocnetHans

  • Vaste Gast
  • **
  • Offline Offline
  • Lid sinds: 2016
  • Ik klooi eigenlijk maar wat aan
    • Scheldekaai
Re: Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
« Reactie #3 Gepost op: zaterdag 02 januari 2021, 15:17:42 »

  @citaat mooi dat het nu werkt.

de Router is een hele mooie functionaliteit binnen Rocrail.
het maakt automatisch alle rijwegen aan incl., wisselstraten. (deze staan dan ook gelijk in de goede stand)
De informatie hiervoor wordt uit het baanplan gehaald, maar je moet de wissels dan wel geadresseerd hebben ander lukt het niet.
Dit is dus anders dan bij Koploper waar het baanplan alleen maar een visueel plaatje is. Daar zitten de relaties tussen blokken in het "spinnenweb".
Hoe iTrain dit regelt weet ik niet.
Het programmeren hiervan is wel een enorme klus geweest heb ik wel begrepen.


de Router maakt dus alle mogelijke rijwegen tussen de blokken aan. Als je de baan maar in één richting berijdt moet je wel voorkomen
dat een loc in een blok keert en terug gaat rijden. Dit kun je doen door in een blok het vinkje "niet keren in blok" aan te zetten, maar
eenvoudiger is in je baanplan richtingpijlen op te nemen. De Router zal dan de tegengestelde rijrichting niet aanmaken.

Gelogd
vr. groet, Hans

dioramabaan "Scheldekaai"
Besturing: digitaal, PC met Rocrail. centrale: DCC++ en Rocnet op Raspberry Pi.
Programmeerspoor met SPROG IIv4
https://forum.3rail.nl/index.php?topic=61263.900

[img]http://files.3rail.nl/419.gif

1200Blauw

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2009
  • NS Tp.IVa (1968-1981)
Re: Rocrail: Geautomatiseerd rijwegen aanmaken lukt niet
« Reactie #4 Gepost op: zaterdag 02 januari 2021, 20:27:40 »

Die pijlen had ik aangebracht, dus dat was goed. Ik loop nu tegen andere problemen aan waardoor ik het hele baanplan opnieuw heb moeten tekenen, maar dat is weer een ander verhaal. Bedankt voor je assistentie tot nu toe :) :thumbup:
Gelogd
Pagina's: [1]   Omhoog
 

Powered by MySQL Powered by PHP SMF 2.0.17 | SMF © 2019, Simple Machines Valid XHTML 1.0! Valid CSS!
Pagina opgebouwd in 0.04 seconden met 23 queries.