Nieuws: Voor de 3railwiki zoeken wij altijd foto's en/of teksten!! Wil je helpen? Lees in de oproep hoe dat kan!
+  3rail Forum
|-+  Modelbaanbesturing & Software
| |-+  PC Besturingsoftware
| | |-+  Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
0 leden en 1 gast bekijken dit topic. « vorige volgende »
Pagina's: [1]   Omlaag

Auteur Topic: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.  (gelezen 788 keer)

Vic1956

  • Zeer Toffe Gast
  • *
  • Offline Offline
  • Lid sinds: 2018
Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Gepost op: zaterdag 09 oktober 2021, 16:52:38 »

Beste treintjesliefhebbers,
Ik ben bezig al mijn locomotieven in Rocrail in te voeren. Dat lukt zonder probleem, behalve dan voor drie oudere machientjes, nog uit mijn beginjaren met deze hobby. Ik heb namelijk geen idee welke instellingen, voor de interface, ik voor deze drie locs moet ingeven om deze via Rocrail te laten werken. Rechtstreeks vanuit de CS3 werken deze locs prima. Maar de communicatie tussen Rocrail en CS3 blijkt, wat deze drie locjes betreft, niet of maar half te lukken.

Loc 1: BR86 uit startset 29530 en loc heeft Marklin nr: 33691.30
Loc 2: Serie 96.020 NMBS Marklin nr: 36743
Loc 3: KLVM 2006 Marklin nr: 36871

De CS3 geeft aan dat voor de drie locs het hier gaat om een MM decoder.
Documentatie Marklin of rail wiki geeft voor de drie locs: FX decoder.
(Ik ben niet zo thuis in dit decoder gedoe, al mijn andere locs zijn MFX of MFX+)

Voor alle drie locs stel ik hetzelfde vast als ik deze locs via Rocrail wil besturen.
Op Rocrail moet ik dan bij “Loceigenschappen”, tab: “interface” het protocol invullen. Ik volg de video van Albert en vul dan in “Server defined”. De CS3 bepaald dan welk protocol toegepast wordt. Maar dan krijg ik via Rocrail geen leven of beweging in deze locjes. Andere protocol mogelijkheden zijn Motorola, MFX, NMRA-DCC, Car, SX1, SX2 WIO-Drive, maar al deze protocols werken in het geheel niet: noch de functies, noch het rijden. Enkel als ik “Motorola” als protocol ingeef kan ik wel de functies bedienen maar rijden lukt niet.

Iemand enig idee wat de oplossing is voor dit probleem?
Alvast bedankt,
Vic
Gelogd

BlikkenTinus

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2016
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #1 Gepost op: zaterdag 09 oktober 2021, 17:05:41 »

Ik denk dat het goed is, bij protocol in RocRail in te vullen: MM of MM2.
En probeer bij rijstsppen 14 en anders 28 te zetten.
Dan zou het moeten lukken om de locjes handmatig te bedienen.

Groet,

Peter
Gelogd

AlbertG

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2011
    • Bouw van mijn baan 'Den Akker'
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #2 Gepost op: zaterdag 09 oktober 2021, 17:55:23 »

Ik heb 1 loc met een vergelijkbare decoder.
Deze staat als volgt ingesteld:
Protocol: ServerDefined, Protocol versie: 2
Snelheidsstappen: 27

Ik hoor graag of het gelukt is.
Gelogd
Albert.
Vooral veel treinen. Alles wat ik mooi vind.
Rocrail / TamsMC / HSI88 / Servo's / gleisbox (SRSEII)
Bouw van mijn baan 'Den Akker': http://forum.3rail.nl/index.php?topic=38912.0
Youtube: https://www.youtube.com/channel/UC1UVuMhBRtDYMIzs-UW-krg

Vic1956

  • Zeer Toffe Gast
  • *
  • Offline Offline
  • Lid sinds: 2018
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #3 Gepost op: zaterdag 09 oktober 2021, 19:43:23 »

Hallo Albert en Peter,
Spijtig, maar geen reactie en geen enkel van de drie locs. Peter, MM staat toch voor Marklin Motorola, vermoed ik?
Toch bedankt, groetjes,
Vic
Gelogd

BlikkenTinus

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2016
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #4 Gepost op: zaterdag 09 oktober 2021, 20:32:45 »

Klopt, Vic, MM is inderdaad Märklin Motorola.
Maar wat merkwaardig dat het niet werkt. Ik heb echt alles rijden, oude Fx decoders, deltadecoders, decoders met potmeters, Esu lokpilots, en Mfx.
En alles rijdt.
Ik stel in RocRail wel alle protocollen in; server defined werkte voor mij niet. Misschien dat je het of allemaal apart moet instellen of alles op server defined moet zetten. Ik heb er voor gekozen in RocRail zo dicht mogelijk aan te sluiten bij wat de betreffende loc in huis heeft en de gegevens zoveel mogelijk af te stemmen op wat in de CS staat.

Groet,

Peter
Gelogd

Anne W

  • Vaste Inboedel
  • ****
  • Offline Offline
  • Lid sinds: 2007
  • Elk vogeltje zingt zoals het gebekt is.
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #5 Gepost op: zaterdag 09 oktober 2021, 22:42:54 »

Kent Rocrail Motorola Oud (1) en Motorola Nieuw (2)?

Groet, Anne W
Gelogd
Raptor, Edits booster 10A, 1 Ma. 6090X decoders 27 staps, 18 MFX decoders(Esu en Mä), 12 met geluid, 28 staps, 27 staps voor de nieuwste Märklin MFX decoders, automatisch bedrijf (Raptor), voor mijn baan zie http://forum.3rail.nl/index.php?topic=6647.0

BlikkenTinus

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2016
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #6 Gepost op: zaterdag 09 oktober 2021, 23:16:36 »

 @citaat ja, beide protocollen zijn bekend bij RocRail!
Gelogd

AlbertG

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2011
    • Bouw van mijn baan 'Den Akker'
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #7 Gepost op: zondag 10 oktober 2021, 10:03:09 »

Kun je nog eens kijken wat er exact staat in de CS3 voor deze locomotieven?
Protocol en rijstappen en eventueel protocol versie?
En welke adressen hebben de locomotieven?
Gelogd
Albert.
Vooral veel treinen. Alles wat ik mooi vind.
Rocrail / TamsMC / HSI88 / Servo's / gleisbox (SRSEII)
Bouw van mijn baan 'Den Akker': http://forum.3rail.nl/index.php?topic=38912.0
Youtube: https://www.youtube.com/channel/UC1UVuMhBRtDYMIzs-UW-krg

Vic1956

  • Zeer Toffe Gast
  • *
  • Offline Offline
  • Lid sinds: 2018
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #8 Gepost op: maandag 11 oktober 2021, 10:36:14 »

Dag Albert,
Citaat
Kun je nog eens kijken wat er exact staat in de CS3 voor deze locomotieven?
Protocol en rijstappen en eventueel protocol versie?
En welke adressen hebben de locomotieven?

De CS3 geeft weinig tot geen informatie, maar misschien is er een mogelijkheid om op de een of andere manier meer informatie op te vragen over het aantal rijstappen bvb. Ik zal dat eens in de handleiding zoeken. Ik heb me hier nooit echt mee bezig gehouden omdat dit een onderdeel (decoders) is waar ik weinig/geen "kaas van gegeten heb". En tot hier toe was daar ook geen noodzaak toe, alles werkte gewoon >:-D

De informatie die de CS3 geeft voor alle drie de locs: decodertype: MM. En als ik Motorola ingeef in Rocrail, bij protocol, dan werken inderdaad de (weinige, KLVM zelfs geen functies) functies van deze locs: lichten en telex koppeling. Alleen het rijden wil niet lukken. Bij de andere mogelijke instellingen die je bij  protocol kan invullen gebeurt er totaal niets: geen functies, geen rijden.

Ik vermoed, vermits de functies werken als ik "Motorola" als protocol invul, er dus wel degelijk communicatie is tussen PC en CS3. Dat het rijden dan niet lukt heeft dan misschien te maken dat het aantal rijstappen, dat ik invul in Rocrail, niet correct is? Er zijn dan ook nog eens twee vakjes om in te vullen bij rijstappen, iets waarvan ik de bedoeling nog niet achterhaald heb maar dat tot hiertoe nooit problemen heeft gegeven.

Ik weet niets van decoders af maar ik vermoed dat er nu ook niet zoveel mogelijkheden zijn in het aantal rijstappen. Ik heb 14, 28 en 27 uitgeprobeerd, zonder succes, zijn er nog andere mogelijkheden? Ik vermoed dat 128 niet dadelijk voor deze decoders in aanmerking komt maar meer gebruikelijk is voor meer recentere mfx decoders?

Alvast bedankt om mee te denken,
Vriendelijke groeten,
Vic
Gelogd

Anne W

  • Vaste Inboedel
  • ****
  • Offline Offline
  • Lid sinds: 2007
  • Elk vogeltje zingt zoals het gebekt is.
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #9 Gepost op: maandag 11 oktober 2021, 15:46:12 »

En welke Motorola, Oud of Nieuw, vul je dan in in Rocrail?

Groet, Anne W
Gelogd
Raptor, Edits booster 10A, 1 Ma. 6090X decoders 27 staps, 18 MFX decoders(Esu en Mä), 12 met geluid, 28 staps, 27 staps voor de nieuwste Märklin MFX decoders, automatisch bedrijf (Raptor), voor mijn baan zie http://forum.3rail.nl/index.php?topic=6647.0

AlbertG

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2011
    • Bouw van mijn baan 'Den Akker'
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #10 Gepost op: maandag 11 oktober 2021, 18:40:03 »

Hoi Vic,
Dat de functies wel werken is een goed teken, dan wordt de loc in ieder geval herkend.
Het tweede veld achter Adres kun je negeren.

Kun je eens het volgende instellen:
Open je werkruimte zoals je gewend bent
Ga naar Bestand - Rocrail Eigenschappen, tabblad Trace.
Zet een vinkje bij de optie Monitor en haal alle andere vinkjes wel als die er staan.
Sluit het venster met OK.

Ga naar het menu 'Beeld' en selecteer de optie 'Trace'
Het Trace venster overlapt nu je hele baanplan maar je kunt de scheiding naar beneden slepen met je muis.
Je hebt nu onder je baanplan 2 extra vensters met links 'Server' en rechts 'Centrale'.
Schakel de voeding in en bedien nu 1 van de probleem locs in Rocrail, dus geeft hem een snelheid van bijvoorbeeld 50.
Dan verschijnt er in het venster onder 'Centrale' 1 of meerdere regels.
Kun je daar een printscreen van maken en die hier plaatsen?

@Anne,
Rocrail maakt geen onderscheid tussen Motorola Oud of Nieuw. Rocrail gaat er standaard van uit dat dit in de centrale geregeld is.
Gelogd
Albert.
Vooral veel treinen. Alles wat ik mooi vind.
Rocrail / TamsMC / HSI88 / Servo's / gleisbox (SRSEII)
Bouw van mijn baan 'Den Akker': http://forum.3rail.nl/index.php?topic=38912.0
Youtube: https://www.youtube.com/channel/UC1UVuMhBRtDYMIzs-UW-krg

Anne W

  • Vaste Inboedel
  • ****
  • Offline Offline
  • Lid sinds: 2007
  • Elk vogeltje zingt zoals het gebekt is.
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #11 Gepost op: maandag 11 oktober 2021, 22:46:53 »

 @citaat

O.K., groet, Anne W
Gelogd
Raptor, Edits booster 10A, 1 Ma. 6090X decoders 27 staps, 18 MFX decoders(Esu en Mä), 12 met geluid, 28 staps, 27 staps voor de nieuwste Märklin MFX decoders, automatisch bedrijf (Raptor), voor mijn baan zie http://forum.3rail.nl/index.php?topic=6647.0

Vic1956

  • Zeer Toffe Gast
  • *
  • Offline Offline
  • Lid sinds: 2018
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #12 Gepost op: dinsdag 12 oktober 2021, 20:44:33 »

Hallo Albert en Anne,
Ik wou deze namiddag uitvoeren wat je mij had aangeraden, Albert, tot ik plots tot de constatatie kwam dat mijn BR 86 wel degelijk begon te rijden. Ook de tweede lok, de S 96, heb ik aan de praat gekregen. Wat was het? Iets heel stom, weer zo iets typisch voor mij >:-D. Ik had Rocrail na het wijzigen van de interface instellingen van de loc, niet afgesloten en weer opgestart. Ik dacht dat dat niet nodig was, verkeerd gedacht dus :D. Nu doordat ik deze middag opnieuw opstartte was dat dus wel gebeurd en mijn loc begon te rijden. Grote vreugde alom!
Beide locs staan dus op Motorola ingesteld, 28 rijstappen en protocol versie staat op 1. De derde loc, het kleine Klvm locje zal ik morgen uit proberen, maar ik vermoed dat dat ook wel zal lukken.

Ik heb nog een klein vraagje, Albert. De Serie 96 loc is zo een goedkoop machientje en daardoor kreeg ik de snelheid via de CS3 niet naar mijn goesting. Het moest trager maar dat lukte van geen kanten. Ik had de instelling Vmax op de CS al op 30 ingesteld en dan ging de loc nog te snel, terwijl de instelbare maximumwaarde 250 is. Ik vermoedde dat deze manier van werken niet de juiste was en heb de max snelheid op de CS dan terug een stuk hoger ingesteld en heb ik in Rocrail, op het tabblad "Snelheid" de snelheidspercentages aangepast, in dit geval dus lager gesteld. Bvb voor Vmid geen 50% maar 30%.
Nu vroeg ik mij af of ik deze manier van werken misschien voor al mijn locs zou moeten toepassen. Dat wil zeggen de Max snelheid op de CS hoog instellen en de verschillende snelheden (min, midden, kruis, max) dan regelen via rocrail door de snelheidspercentages op het tabblad "Snelheid" aan te passen. Ik vermoed, maar verbeter mij als ik verkeerd ben, dat als je een hoge max snelheid voor je loc op de centrale instelt en dan met de percentages bij regelt in rocrail, dit tot een betere regeling leidt dan te vertrekken van een laag ingestelde maximum snelheid op de centrale. Of maakt dit niet zo uit?

Alvast bedankt voor de hulp,
Groeten, Vic
Gelogd

AlbertG

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2011
    • Bouw van mijn baan 'Den Akker'
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #13 Gepost op: woensdag 13 oktober 2021, 09:36:41 »

Hoi Vic,
Mooi dat het werkt. Normaal gesproken hoef je Rocrail niet opnieuw op te starten als je iets in de loc eigenschappen hebt aangepast.
Misschien dat het iets met de synchronisatie tussen Rocrail en je CS3 te maken heeft waardoor het nu wel werkt.

Het uitgangspunt van Rocrail is dat je de snelheid van de loc regelt via de decoderinstellingen. Ik raad je aan dat ook zo te doen.
Als ik daarna vind dat een loc net iets te snel of te langzaam rijdt pas in de snelheidsinstellingen in Rocrail aan. Vmid wordt dan bijvoorbeeld 48 of 52.
Als een oudere decoder niet zo goed in te stellen is kun je dat dus prima via Rocrail regelen.
Als je namelijk de snelheid in Rocrail regelt kom je later in de problemen als je een loc netjes wilt leren remmen (BBT). Je hebt dan heel weinig regelruimte.
Maar dat ga je zien als je je gaat verdiepen in BBT. Eerst maar een zorgen dat alles rijdt en schakelt.

Succes,
Albert.
Gelogd
Albert.
Vooral veel treinen. Alles wat ik mooi vind.
Rocrail / TamsMC / HSI88 / Servo's / gleisbox (SRSEII)
Bouw van mijn baan 'Den Akker': http://forum.3rail.nl/index.php?topic=38912.0
Youtube: https://www.youtube.com/channel/UC1UVuMhBRtDYMIzs-UW-krg

Vic1956

  • Zeer Toffe Gast
  • *
  • Offline Offline
  • Lid sinds: 2018
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #14 Gepost op: woensdag 13 oktober 2021, 11:47:20 »

Albert,
Ik ben al bezig geweest met BBT en dat geeft zeer mooi resultaat, alleen: enorm tijdrovend.

Nu vroeg ik mij het volgende af:
Mijn stationssporen, waar ik BBT wens toe te passen, hebben ongeveer dezelfde lengte, (paar cm verschil). Als ik voor één van deze sporen mijn loc 10 à 15 keer heb doen stoppen om de computer de berekening te laten maken om mooi in 10 stappen af te remmen, kan ik dan deze berekende waarden gewoon overnemen/kopiëren naar de ander blokken waar BBT van toepassing is? Of moet dat proces van 10 à 15 maal afremmen, telkenmale voor elk blok met BBT herhaald worden?

En, indien ja op bovenstaande vraag, kan ik deze waarden dan ook als richtwaarden gebruiken voor andere locs om sneller tot het gewenste resultaat te komen, om aldus bvb in een vijftal keren stoppen, tot een correcte berekening te komen? Ik heb namelijk nogal wat locs.

Groeten,
Vic
Gelogd

AlbertG

  • Stamgast
  • ***
  • Offline Offline
  • Lid sinds: 2011
    • Bouw van mijn baan 'Den Akker'
Re: Probleem bij het invoeren van drie, al wat oudere, locs op Rocrail.
« Reactie #15 Gepost op: woensdag 13 oktober 2021, 16:52:54 »

Hoi Vic,
Je kunt de regels inderdaad kopiëren. Je moet dan per nieuwe regel het blok aanpassen waarop de regel van toepassing is.
Om het proces te versnellen kun je ook de parameters waarmee de tijden worden gecorrigeerd aanpassen. Raadpleeg de wiki voor de details.

Overigens bemoei ik me meestal weinig of niet met dit proces. Ik laat de treinen gewoon rijden en als ik denk dat de BBT waarden zo'n beetje kloppen dan bevries ik ze. De eerste keer rijdt de loc dan inderdaad tergend langzaam van de Enter naar de In melder maar de tweede keer gaat het al een stuk sneller.
Gelogd
Albert.
Vooral veel treinen. Alles wat ik mooi vind.
Rocrail / TamsMC / HSI88 / Servo's / gleisbox (SRSEII)
Bouw van mijn baan 'Den Akker': http://forum.3rail.nl/index.php?topic=38912.0
Youtube: https://www.youtube.com/channel/UC1UVuMhBRtDYMIzs-UW-krg
Pagina's: [1]   Omhoog
 

Powered by MySQL Powered by PHP SMF 2.0.17 | SMF © 2019, Simple Machines Valid XHTML 1.0! Valid CSS!
Pagina opgebouwd in 0.079 seconden met 27 queries.